Deposits, withdrawals and trading have been halted for TRUF
Incident Report for Bitstamp
Identified
We’ve proactively halted all deposits, withdrawals, and trading for TRUF/USD and TRUF/EUR pairs as of October 30, 2024.

For more information on the situation please see: https://blog.bitstamp.net/post/truf-token-migration-and-trading-halt/
Posted Nov 05, 2024 - 13:37 UTC
Investigating
Trading has been halted for TRUF/USD and TRUF/EUR markets.
Posted Oct 30, 2024 - 16:04 UTC