Resolved
This incident has been resolved.
Posted Apr 20, 2026 - 15:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 15:20 UTC
Identified
We are currently experiencing issues with all withdrawals and deposits and we are working on a fix.
Posted Apr 20, 2026 - 15:01 UTC
This incident affected: Deposits (ADA, ALGO, AVAX, BCH, BTC, DOGE, DOT, ETH & ERC20, FLR, HBAR, LTC, NEAR, SGB, SOL & SPL tokens, SUI, XLM, XRP, CSPR, EGLD, ICP, XDC) and Withdrawals (ADA, ALGO, AVAX, BCH, BTC, DOGE, DOT, ETH & ERC20, FLR, HBAR, LTC, NEAR, SGB, SOL & SPL tokens, SUI, XLM, XRP, CSPR, EGLD, ICP, XDC).