Issues with ETH withdrawals

Incident Report for Bitstamp

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 13:19 UTC

Investigating

We are currently experiencing issues with ETH withdrawals. We are investigating the issue.
Posted Jun 10, 2026 - 13:12 UTC
This incident affected: Withdrawals (ETH & ERC20).