Issues with FLR withdrawals

Incident Report for Bitstamp

Resolved

Issue is resolved.
Posted Jun 03, 2026 - 09:00 UTC

Identified

We are currently experiencing issues with FLR withdrawals. We are investigating the issue.
Posted Jun 03, 2026 - 08:09 UTC
This incident affected: Withdrawals (FLR).