Issues with platform

Incident Report for Bitstamp

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 12:44 UTC

Update

We are currently investigating an issue affecting logins on our public pages. Trading is unaffected. We will provide another update as soon as we have more information.
Posted Aug 03, 2026 - 12:18 UTC

Update

We are continuing to investigate this issue.
Posted Aug 03, 2026 - 12:13 UTC

Investigating

We are experiencing issues with our platform. We are currently investigating the issue.
Posted Aug 03, 2026 - 12:07 UTC
This incident affected: Web and Mobile app.